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What’s in this Tutorial

This tutorial describes how to re-engineer a program or programs under an application area. This creates re-engineered components for the program being re-engineered, i.e.

· Component Source member (Shadow program) having the Business logic held in the program and

· Screen Function Name used by X-Browse to present data in the files that program uses.

The Generate Business Rules and Re-engineer Program options are available for RPG programs only.

So let’s go ahead with the tutorial and explore the re-engineering capability of the X-Analysis product.

The Demo Library used for this tutorial is AXRAPPS and all options have been demonstrated on RPGLE object CUSFMAINT.

Expand the library AXRAPPS, double click on Programs in the navigation pane to bring up the Work with Objects dialog. Select RPGLE as the attribute and click OK. All RPGLE type objects are displayed.
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Object List listing all RPGLE Programs

Re-engineering a Program

X-Analysis gives an option to Re-engineer RPG programs. Right click on the CUSFMAINT object and opt for Re-engineer Program.

	This presents a dialog with Application Library initialized to *XALIB, implying that it will generate the application data in the X-Analysis X-Reference library.  Check the Replace Data Model and Update Screens checkboxes if required. Click the OK button to Re-engineer the program CUSFMAINT.
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Re-engineer Program Dialog


This presents the Re-engineer Business Rule Program Progress dialog, which interactively and independently displays the status. 
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Re-engineer Business Rule Program Progress Dialog

The Task Completed message is displayed once the process is complete. Any error encountered during the re-engineering process is recorded in the text window as job log.

Right click on CUSFMAINT and opt for Re-engineered Programs & Screens. This displays the Re-engineered Programs & Screens List for the application library.
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Re-engineer Components dialog showing components generated for CUSFMAINT
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	The Re-engineered Programs & Screens option in the Navigation Pane displays all the Re-engineered Programs & Screens for the application or the selected application area.


The re-engineered components produced for CUSFMAIN are:

· Component source member ZZCUSFMAIN, better understood as a shadow program which will act on,

· The Screen Function - ZZCUSFMAINS1.

Let us look at the components produced.

View Component Source Member

Opt for Zoom on source on ZZCUSFMAIN to see the Component Source Member in Source Browser View.
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Part of Validation routine generated for ZZCUSFMAIN shadow program

The above view displays the Validation code for CUSFMAINT along with the business rules, while the view on the next page shows the validation code as it exists in CUSFMAINT.
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Part of Validation code on CUSFMAINT program

Refer to the Business logic shown by X-Analysis Source Browser screen.

The shadow program ZZCUSFMAIN is used to validate any entries made using the screen ZZCUSFMAINS1.

Function Layout
In the Re-engineered Programs & Screens for Application Library AXRAPPS view, right click on ZZCUSFMAIN and opt for Function Layout option. This presents the data in the file on which the Screen component is built, in X-Browse.
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Customer Site Maintenance screen displayed using ZZCUSFMAIN Screen function

Enter the alphabets ‘ABCD’ as the telephone number in the above screen, and then click the Validate button. You will see the message ‘The telephone no. is invalid’ in red on the status bar. The shadow program ZZCUSFMAIN is used to validate the entries in this screen. 

Clicking the Update button also triggers the validate routines first, before updating the record.

	User can change the function layout by opting for Function Design. 
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Viewing Dependent functions

The dependents for any file may be viewed in X-Browse by selecting View>Dependent Functions. The dependents show up in the dependents panel in the form of a grid.

Select View>Dependent Functions for ZZCUSFMAIN.
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Dependent Grid for ZZCUSFMAIN

The display of dependents may be altered to suit the needs of the user. The following steps carried out on ZZCUSFMAIN, the shadow program for CUSFMAINT demonstrate this feature of X-Browse.

	Double click on the Re-engineered Programs & Screens option on the navigation pane, to bring up the list of Re-engineered Programs and screens.
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Right click on the Component Source Member ZZCUSFMAIN, and select the Function Layout option.

If ZZCUSFMAIN does not appear in the Re-engineered Programs and Screens List, then the program CUSFMAIN has to be reverse engineered to generate ZZCUSFMAIN.

X-Browse is invoked displaying ZZCUSFMAIN along with its three dependents viz. Work with Customer Contacts, Distributors and Work with Representative Delivery Areas. Select each tab and view the records displayed.

Click the Function Design button and then select the Function Maintenance designer tab.

Defining Header Section

Under the Control Flags section, enter ‘4’ as the Header Dividing Line No..

	The Header Dividing Line No. option accepts a numerical value between 1 to 9 and is only available for flat screen functions.

This option is used to define a header for the screen. The value entered determines the number of fields from top to be included in the header.

The remaining fields are displayed under a General tab.

Select OK and then click on Exit.
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Header Dividing Line No. option under Function Maintenance


The screen is now split in two halves, separated by a row of buttons. The top half is the header, which has only 4 fields, while the remaining fields are displayed under the General tab.
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ZZCUSFMAINS1 – Before Setting Header
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ZZCUSFMAINS1 -  After Setting Header

Click on the remaining buttons to view the dependent records.

Stored Procedure Calls

	Again click on the Function Designer button, and select the Function Maintenance tab.

To ensure that the validation routines are called before a record is updated, the validation option under Stored Procedure Calls in the Function Maintenance tab has to be selected.

Click the button next to the validation option. 

X-Analysis is invoked, and the source browser opens to display the validation subroutine.
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Stored Procedure Calls


Setting the Dependents Option

Next, select the Dependents tab.
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Dependents Tab in Function Designer View

This tab displays the list of dependents for the present function. A dependent function equates to a child in the parent-child relationship of the data model, where the parent is the record being displayed in the RECORD function.

Dependent on Alternate Key

Dependents are of two types:

1. Regular Dependents, i.e. those that form a relation with the parent using a key field. These are identified during the Data Modeling process.

2. Dependents formed using Alternate Key(s): These are based on a field(s) or key structure different from the PID. The Alt. Key checkbox when checked presents the Dependent on Alternate keys dialog. Using this dialog, non-primary key field(s) may be mentioned which will form the basis of this relationship.

In the current example, Distributors and Work with Representative Delivery Areas are dependents formed using Alternate Keys.

Write Function

This option if selected makes the dependent function show up in a flat screen view, with the first record on display. This view is very useful for adding dependent records.
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Distributors Tab showing dependents in flat screen view

Generate JSF ,Javabean(s) and UML

· Before proceeding further go to X-Analysis>X-Analysis Tools>X-Browse Configuration wizard  and ensure that the following settings have been made:

1. Application Settings: Under the X-App Interface section, the Studio Folder path (WebSphere or Eclipse) has to be mentioned. The path for the Web Server folder should also be entered.

2. Interface: Under the X-Web Interface section, the X-Web URL along with the port number has to be correctly mentioned. E.g. http://192.168.170.27:8080

If any of the above are to be changed, then X-Analysis has to be restarted for them to take effect.

	Now select the Generate JSF, Javabean(s) and UML option from the right click menu over ZZCUSFMAINS1 Screen Function Name.
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Right Click Menu on Component Source Member


The menu option Generate JSF, Javabean(s) and UML does the following :

A. Generates the project (if it has not already been generated) with the same name as <APPLIB> at: C:\WDSC\WSSD\workspace

e.g. the directory C:\WDSC\WSSD\workspace\Axrapps is created with the project contents.

B. Configures the plug-in for editing JSF pages in WDSC. The plug-in gets installed under the WDSC's 'plugins' dir at :

C:\Program Files\IBM\WebSphere Studio\ SiteDeveloper\ v5.1.2 \ eclipse\ plugins\ com.databorough.config.project_1.0.0

C. Creates the Context (below the X-Web Context) with the same name as <APPLIB> at :

C:\Program Files\Tomcat\conf\server.xml

as shown below :

<!-- X-Web Context -->

<Context path="/xw" docBase="C:/Program Files/X-Web/server" crossContext="true"/>

<!-- Axrapps Context -->

<Context path="/axrapps" docBase="C:/WDSC/WSSD/workspace/Axrapps/jsf"

crossContext="true" />

D. Generates the JSF page (.jsp) with the same name as 'Screen Function Name' at:


C:\WDSC\WSSD\workspace\<APPLIB>\jsf 


e.g. the file ZZCUSFMAINS1.jsp is generated in C:\WDSC\WSSD\workspace\Axrapps\jsf 

E. Generates the Java bean source (.java) with the same name as ' Screen Function Name' in :


C:\WDSC\WSSD\workspace\<APPLIB>\com\databorough\storedprocedure\access


e.g. the file ZZCUSFMAIN.java is generated in 

C:\WDSC\WSSD\workspace\Axrapps\com\databorough\storedprocedure\access

Compiles the above Java bean source and creates its object (.class) in :

C:\WDSC\WSSD\workspace\<APPLIB>\jsf\WEBINF\classes\com\databorough\ storedprocedure\access

e.g. the file ZZCUSFMAINS1.class is created in :

C:\WDSC\WSSD\workspace\Axrapps\jsf\WEBINF\classes\com\databorough\ storedprocedure\access

F. Finally launches the WDSC. When the WDSC is launched, these steps have to be performed :

I. Choose the menu Window | Customize Perspective… if using WDSC 5.1.2.
II. In the ‘Customize Perspective’ dialog, expand the ‘Other’ item, check the option ‘Register Project’ from the list, and click the ‘OK’ button.

The menu changes to show the menu item with the same name as the cross reference library, e.g. AXRAPPS. The toolbar also changes to show the toolbar item with the tool tip ‘Register <APPLIB> project in Workspace’.

III. Click on this menu item <APPLIB> | Register Project. Wait till the project is registered and you get the message ‘Project <APPLIB> registered’. The <APPLIB> project now appears in the ‘Package Explorer’ in Java Perspective (Window > Open Perspective > Java) or in the ‘Project Navigator’ in Web Perspective (Window > Open Perspective > Web).

The steps I & II are only required for the first time, to register the plug-in with the workspace. The step III is required every time the WDSC is launched.

The menu option <APPLIB>|Register Project apart from synchronizing the directory contents with the workspace starts the XML-RPC server (Apache's Remote Procedure Call HTTP server) internally so that the WDSC can listen to XA/XB requests.

	For using the Generate JSF,Javabean(s) and UML option either the WebSphere Studio or Java2SDK has to be installed on the machine.

For displaying and editing the generated JSF and Javabean(s), either Eclipse Studio or WebSphere Studio Site Developer has to be installed.

	If the project is not configured in the default editor then the following message is displayed.

Click on the Configure button. This will open WebSphere or Eclipse.
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Configure Project in Eclipse Studio Dialog


Go back to Re-engineered Programs & Screens list, and select Function Layout from the right click menu on ZZCUSFMAIN. Note that in the function designer view for ZZCUSFMAIN, the Drag and Drop tab is replaced by Edit JSF.
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Edit JSF tab in Function Designer View

The Design Web Page button invokes WebSphere or Eclipse and opens the generated JSF for editing.

Edit JSF in WebSphere

This option allows the generated JSF to be edited either from its source or in the view mode using WebSphere.

For any troubleshooting regarding JSF’s refer to Appendix – A.

	For editing JSF or Java bean first click on the Open WebSphere Studio button. Once the WebSphere Studio is up and running, select the Edit JSF option from the right click  menu over ZZCUSFMAIN.
	[image: image21.png]





The generated JSF and Java bean file are displayed in WebSphere Studio. Along with these, the dependents of ZZCUSFMAIN are also shown as java files.
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Source View of generated JSF

For viewing the design view of the JSF, select the Design option.
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Design View of generated JSF

The javabean ZZCUSFMAINS1.java which acts on ZZCUSFMAINS1.jsp may also be displayed.
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Generated Javabean displayed in WebSphere Studio

Structure of Generated Files

Following is the basic structure of the JSF and Javabean generated using the Generate JSF,Javabean(s) & UML option:

Basic structure of Javabean (ZZCUSFMAINS1.java)

	package com.databorough.storedprocedure.access
	Package Declaration

	import java.util.Date;

import com.ibm.as400.access.AS400;
	Import Statements

	public class ZZCUSFMAINS1 extends AbstractStoredProcedureCall
	Class Declaration

	public
static final String
fun = "ZZCUSFMAINS1";
	Biz. Rule Program

	public
static final String
storedProc= "ZZCUSFMAIN";
	Stored Procedure called by ‘fun’

	public

static final String[]

pidNames =


{



"CUSNO"


};

public

static final String[]

constant =


{


};

……………..
	Array Declaration for PIDs, Labels, Fields and their length.

	public ZZCUSFMAINS1()

{


super();

}
	A No-Argument Constructor

	public ZZCUSFMAINS1(AS400 as400)

{


super(as400);

}
	Constructor with iSeries object as argument

	public ZZCUSFMAINS1(String userId)

{


super(userId);

}
	Constructor with User ID as argument

	public ZZCUSFMAINS1(String systemName, String userId, String password)

{


super(systemName, userId, password);

}
	Constructor with System Name, User ID and Password of an iSeries Server

	protected void prepareSpec()

{

…………

}
	Sets this bean’s specification (For internal use)

	protected void setClassObj()

{


this.classObj = this;

}
	Sets this bean’s instance (For internal use)


	public String getZZDATE_LABEL()

{


return (ZZDATE_LABEL == null ? " " : ZZDATE_LABEL);

}
	Getter method for constants / labels

	public String getZZDATE()

{


return (ZZDATE == null ? " " : ZZDATE);

}
	Getter method for fields

	public void setZZDATE(String ZZDATE)

{


this.ZZDATE = ZZDATE;


setFieldValue("ZZDATE", ZZDATE);

}


	Getter method for fields

	public String getZZCUSFMAINS1()

{


return (ZZCUSFMAINS1 == null ? "/axrapps2/faces/" : ZZCUSFMAINS1);

}
	Gets the Biz. Rule pgm link

	public String getAACNTACS_CNTACS_CUSF()

{
return (AACNTACS_CNTACS_CUSF == null ? "/axrapps2/faces/" : AACNTACS_CNTACS_CUSF);

}
	Gets the Biz. Rule program’s dependent links

	public void setZZCUSFMAINS1(String ZZCUSFMAINS1)

{

}
	Sets the Biz. Rule Program’s link

	public void setAACNTACS_CNTACS_CUSF(String AACNTACS_CNTACS_CUSF)

{


this.AACNTACS_CNTACS_CUSF = AACNTACS_CNTACS_CUSF;

}
	Sets the Biz. Rule Program’s dependent’s link


Basic Structure of JSF

· HTML Tags (Title,Header,Links…)

· <BODY>

· Page Directives, defining the attributes that apply to the entire page.

· Use Bean Action: locates or instantiates a bean with a specific name and scope

· SetProperty element: sets the value of one or more properties in a bean, using the bean's setter methods

· Scriptlets: These are small scripts that are used to add small pieces of java code in a JSP page

· ServletContext: Sets the Servlet Context, Request and Response.

· String[] pids: Sets the Primary Identifiers.

· Some more scriplets.

· <f:view>: The view is a container for all JavaServer Faces core and custom component actions used on a page.

· <FORM>

· Nested Tables defining the structure of the page.

· </FORM>

· </f:view>

· </BODY>

· </HTML>

Execute JSF

Select Execute JSF option on ZZCUSFMAIN. This opens the JSF single record in the name ZZCUSFMAINS1 in X-Web.
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ZZCUSFMAINS1 in X-Web

The generated web page is a blend of both the single record JSF and its Dependent grid JSF. 

X-Web Server should be running for Execute JSF option to render the page on browser.

Convert to Java

	This option available on the right click menu over any Component source member converts the source into Java.
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Right Click menu on Component Source Member
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Convert to Java Progress Dialog

The generated java code may be viewed in WebSphere, if the Generate JSF,Javabean(s) & UML option is taken on the Component Source Member. The java file is visible in the shadow programs package of the project. If the java file is not visible, then refresh the project.

Designing a Function

Select Function Layout from the right click menu on ZZCUSFMAIN. This will open X-Browse and display the Contract detail grid.
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	Click on the Function Design button from the toolbar to edit the Field Layout. This splits the view and presents the designer tabs in the lower half. By default the Field Layout tab is open.
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Function Layout Design

Make some changes in the field layout.

Next, Click on the Drag and Drop design tab.
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Drag and Drop on ZZCUSFMAIN

Drag and drop some labels/text fields to rearrange the screen.

Click OK to save the changes.

Close X-Browse and then opt for the Generate JSF and Javabean(s) option on ZZCUSFMAIN. Use Execute JSF  to display the changed JSF’s. 

With this we come to the end of this tutorial.

Appendix – A Troubleshooting JSF Project

Problem: The <APPLIB> menu item does not show up in WDSC.

Solution: This means either the plug-in has not been registered with the workspace (i.e. this is first project configured using X-Analysis) or the project has not been generated.
If the project has been generated and this is the first project configured using X-Analysis, follow these steps :

1. Expand the application library and double click on the icon [image: image31.png]


 ‘Re-engineered Programs & Screens’ in X-Analysis. Next, to start WebSphere, click on the icon [image: image32.png]


 ‘Open WebSphere Studio’ on the toolbar.

2. Choose the menu Window | Customize Perspective… in WebSphere Studio.

3. In the ‘Customize Perspective’ dialog, expand the ‘Other’ item, check the option ‘Register Project’ from the list, and click the ‘OK’ button. The menu changes to show the menu item with the same name as the cross reference library, e.g. XAN4CDXA. The toolbar also changes to show the toolbar item with the tool tip ‘Register <APPLIB> project in Workspace’.

4. Click on this menu item <APPLIB> | Register Project. Wait till the project is registered and you get the message ‘Project <APPLIB> registered’. 

The <APPLIB> project now appears in the ‘Package Explorer’ in Java Perspective (Window > Open Perspective > Java) or in the ‘Project Navigator’ in Web Perspective (Window > Open Perspective > Web).

If the project has not been generated using X-Analysis, follow these steps :

1. Generate the project by right clicking on any business rule program and opting for ‘Generate JSF, Javabean(s) and UML’ and following the on-screen instructions. 

2. When the WDSC is launched, click on the menu item <APPLIB> | Register Project. 

3. Wait till the project is registered and you get the message ‘Project <APPLIB> registered’. 

The <APPLIB> project now appears in the ‘Package Explorer’ in Java Perspective (Window > Open Perspective > Java) or in the ‘Project Navigator’ in Web Perspective (Window > Open Perspective > Web).

Problem: 

The <APPLIB> project does not appear in the ‘Package Explorer’ in Java Perspective (Window > Open Perspective > Java) or in the ‘Project Navigator’ in Web Perspective (Window > Open Perspective > Web).

Solution:
This implies that the menu item ‘<APPLIB> | Register Project’ was never clicked. Click on this menu item.

 Wait till the project is registered and you get the message ‘Project <applib> registered’.

The <APPLIB> project now appears in the ‘Package Explorer’ in Java Perspective (Window > Open Perspective > Java) or in the ‘Project Navigator’ in Web Perspective (Window > Open Perspective > Web).

If none of the above three problems arise, but still the page title does not show the word ‘(JSF)’ as part of the title, that means the servlet page is being rendered instead of the JSF page. 

The possible reasons are listed below :

i. The JSF page (.jsp) does not exist in : 

C:\WDSC\WSSD\workspace\<APPLIB>\jsf.

ii. The Java bean source (.java) does not exist in :


C:\WDSC\WSSD\workspace\<APPLIB>\com\databorough\storedprocedure\access

It should also be visible in the project's com.databorough.storedprocedure.access package in WDSC. If not right-click on this package and click 'Refresh'.

iii. The Java bean object (.class) does not exist in :


C:\WDSC\WSSD\workspace\<APPLIB>\jsf\WEB-INF\classes\com\databorough\storedprocedure\access

iv. The Context for the APPLIB does not exist in :

C:\Program Files\Tomcat\conf\server.xml

e.g.

<!-- Xan4cdxa Context -->

<Context path="/xan4cdxa" docBase="C:/WDSC/WSSD/workspace/Xan4cdxa/jsf"

crossContext="true" />

v. The JSF page (.jsp) does not get converted to Servlet page (.java) in :

C:\Program Files\Tomcat\work\Standalone\localhost\<APPLIB>

as <jsp>$jsp.java

e.g. zacusts$jsp.java

vi. The Servlet page (.java) does not get compiled to object (.class) in :

C:\Program Files\Tomcat\work\Standalone\localhost\<APPLIB>

as <jsp>$jsp.class

e.g. zacusts$jsp.class

To resolve errors i. to vi., follow these steps in WDSC :

1. Click on the project in the ‘Package Explorer’ window and opt for the menu ‘Project | Rebuild Project’.

2. Right click on the project and choose ‘Properties’.

3. In the ‘Properties for <Applib>’ dialog, choose ‘Java Compiler’ and click on OK. 

[image: image33.png]The compler settings have changed. A rebuld of the project s required to
make changes effective, Da the project buld now?

e W





Compiler Settings Dialog

4. Click on the ‘Yes’ button.

5. After some time the project is rebuilt. Expand the project in the ‘Package Explorer’, further expand the ‘jsf’ node and double click on the jsp file which should be opened on the RHS.

Note:

The error log WebSphere may be viewed at:

Window > Show View > Other... > PDE Runtime > Error Log

Apart from the error log, a .log file is also generated by WDSC at C:\WDSC\WSSD\workspace\.metadata. 

In the Windows Explorer there would be nothing under the 'Name' column but the 'Type' column would be showing the 'LOG File'.

The following are the steps for deleting any project in WebSphere :

1. Stop X-Web Server i.e. Tomcat, if running.

2. Click on the project in the 'Package Explorer' and press Delete key. You should get the 'Confirm Project Delete' dialog with 2 options :

a. Also delete contents under 'C:\WDSC\WSSD\workspace\<APPLIB>'

b. Do not delete contents

Choose the first option.

3. Exit WebSphere.
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